ошибка при установке зависимостей php на ubuntu

у меня впс с linux ubuntu 20.04 LTS установлен, я также установил стек ламп для загрузки своих веб-проектов, php с версией 7.4, теперь мне нужно установить еще несколько php-библиотек, например: php-gd поэтому выполните команду:

sudo apt-get install php7.4-gd

но при установке получаю следующую ошибку: php7.4-cli : Depends: php7.4-common (= 7.4.3-4ubuntu2.18) but 7.4.3-4ubuntu2.17 is to be installed

и на самом деле он не позволит мне установить что-либо еще, потому что он всегда выдает мне эту ошибку … есть идеи, как это решить?

2 ответа
2

Проверять /etc/apt/sources.list и посмотрите, содержит ли он строку:

deb http://... focal-security main restricted universe multiverse

Линия выглядит немного иначе, но самое главное, что у вас есть фокальная безопасность репозиторий включен, так как там доступна версия 7.4.3-4ubuntu2.18.

Затем обновите репо apt update и попробуй еще раз apt install php7.4-gd.

В розыске

Сначала установите пакет software-properties-common на Ubuntu

Басант Мандал

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *