Не удается установить VLC Media Player на Fedora 34

когда я пытаюсь установить VLC # dnf install vlc , я получаю эти ошибки:

Error: 

Problem: package vlc-1:3.0.16-1.fc34.x86_64 requires vlc-core(x86-64) = 1:3.0.16-1.fc34, but none of the providers can be installed
  - package vlc-1:3.0.16-1.fc34.x86_64 requires libvlccore.so.9()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides live555(x86-64) = 2020.07.31 needed by vlc-core-1:3.0.16-1.fc34.x86_64
  - nothing provides libx264.so.161()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64
  - nothing provides libx265.so.199()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64
  - nothing provides libfaad.so.2()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64
  - nothing provides libdca.so.0()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64  
  - nothing provides libBasicUsageEnvironment.so.1()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64
  - nothing provides libUsageEnvironment.so.3()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64
  - nothing provides libgroupsock.so.8()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64
  - nothing provides libliveMedia.so.79()(64bit) needed by vlc-core-1:3.0.16-1.fc34.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Я не понимаю, почему там написано конфликтующие запросы

Затем я попытался установить зависимости вручную:

# dnf deplist vlc

и получил:

package: vlc-1:3.0.16-1.fc34.x86_64
  dependency: /bin/sh
   provider: bash-5.1.0-2.fc34.x86_64
  dependency: /usr/bin/sh
   provider: bash-5.1.0-2.fc34.x86_64
  dependency: dejavu-sans-fonts
   provider: dejavu-sans-fonts-2.37-16.fc34.noarch
  dependency: dejavu-sans-mono-fonts
   provider: dejavu-sans-mono-fonts-2.37-16.fc34.noarch
  dependency: dejavu-serif-fonts
   provider: dejavu-serif-fonts-2.37-16.fc34.noarch
  dependency: hicolor-icon-theme
   provider: hicolor-icon-theme-0.17-10.fc34.noarch
  dependency: libQt5Core.so.5()(64bit)
   provider: qt5-qtbase-5.15.2-16.fc34.x86_64
  dependency: libQt5Core.so.5(Qt_5)(64bit)
   provider: qt5-qtbase-5.15.2-16.fc34.x86_64
  dependency: libQt5Core.so.5(Qt_5.15)(64bit)
   provider: qt5-qtbase-5.15.2-16.fc34.x86_64
  dependency: libQt5Gui.so.5()(64bit)
   provider: qt5-qtbase-gui-5.15.2-16.fc34.x86_64
  dependency: libQt5Gui.so.5(Qt_5)(64bit)
   provider: qt5-qtbase-gui-5.15.2-16.fc34.x86_64
  dependency: libQt5Svg.so.5()(64bit)
   provider: qt5-qtsvg-5.15.2-4.fc34.x86_64
  dependency: libQt5Svg.so.5(Qt_5)(64bit)
   provider: qt5-qtsvg-5.15.2-4.fc34.x86_64
  dependency: libQt5Widgets.so.5()(64bit)
   provider: qt5-qtbase-gui-5.15.2-16.fc34.x86_64
  dependency: libQt5Widgets.so.5(Qt_5)(64bit)
   provider: qt5-qtbase-gui-5.15.2-16.fc34.x86_64
  dependency: libQt5X11Extras.so.5()(64bit)
   provider: qt5-qtx11extras-5.15.2-3.fc34.x86_64
  dependency: libQt5X11Extras.so.5(Qt_5)(64bit)
   provider: qt5-qtx11extras-5.15.2-3.fc34.x86_64
  dependency: libX11.so.6()(64bit)
   provider: libX11-1.7.2-3.fc34.x86_64
  dependency: libXext.so.6()(64bit)
   provider: libXext-1.3.4-6.fc34.x86_64
  dependency: libXinerama.so.1()(64bit)
   provider: libXinerama-1.1.4-8.fc34.x86_64
  dependency: libXpm.so.4()(64bit)
   provider: libXpm-3.5.13-5.fc34.x86_64
  dependency: libc.so.6(GLIBC_2.27)(64bit)
   provider: glibc-2.33-20.fc34.x86_64
  dependency: libfluidsynth.so.2()(64bit)
   provider: fluidsynth-libs-2.1.8-3.fc34.x86_64
  dependency: libfreetype.so.6()(64bit)
   provider: freetype-2.10.4-3.fc34.x86_64
  dependency: libfribidi.so.0()(64bit)
   provider: fribidi-1.0.10-4.fc34.x86_64
  dependency: libgcc_s.so.1()(64bit)
   provider: libgcc-11.2.1-1.fc34.x86_64
  dependency: libgcc_s.so.1(GCC_3.0)(64bit)
   provider: libgcc-11.2.1-1.fc34.x86_64
  dependency: libgcc_s.so.1(GCC_3.3.1)(64bit)
   provider: libgcc-11.2.1-1.fc34.x86_64
  dependency: libjack.so.0()(64bit)
   provider: jack-audio-connection-kit-1.9.17-1.fc34.x86_64
   provider: pipewire-jack-audio-connection-kit-0.3.33-3.fc34.x86_64
  dependency: libm.so.6()(64bit)
   provider: glibc-2.33-20.fc34.x86_64
  dependency: libm.so.6(GLIBC_2.2.5)(64bit)
   provider: glibc-2.33-20.fc34.x86_64
  dependency: libm.so.6(GLIBC_2.27)(64bit)
   provider: glibc-2.33-20.fc34.x86_64
  dependency: libm.so.6(GLIBC_2.29)(64bit)
   provider: glibc-2.33-20.fc34.x86_64
  dependency: libpthread.so.0()(64bit)
   provider: glibc-2.33-20.fc34.x86_64
  dependency: libpthread.so.0(GLIBC_2.2.5)(64bit)
   provider: glibc-2.33-20.fc34.x86_64
  dependency: libpulse.so.0()(64bit)
   provider: pulseaudio-libs-14.2-3.fc34.x86_64
  dependency: libpulse.so.0(PULSE_0)(64bit)
   provider: pulseaudio-libs-14.2-3.fc34.x86_64
  dependency: libstdc++.so.6()(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(CXXABI_1.3)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(CXXABI_1.3.8)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(CXXABI_1.3.9)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(GLIBCXX_3.4)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(GLIBCXX_3.4.29)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
   provider: libstdc++-11.2.1-1.fc34.x86_64
  dependency: libvlccore.so.9()(64bit)
   provider: vlc-core-1:3.0.16-1.fc34.x86_64
  dependency: libwayland-client.so.0()(64bit)
   provider: libwayland-client-1.19.0-1.fc34.x86_64
  dependency: rtld(GNU_HASH)
   provider: glibc-2.33-20.fc34.i686
   provider: glibc-2.33-20.fc34.x86_64
  dependency: vlc-core(x86-64) = 1:3.0.16-1.fc34
   provider: vlc-core-1:3.0.16-1.fc34.x86_64
  dependency: xdg-utils
   provider: xdg-utils-1.1.3-9.fc34.noarch

Я установил каждый из них, но все равно получаю первую ошибку.

(Я попытался установить VLC на другой Fedora 34 и не получил этих ошибок, и он был успешно установлен и работал без каких-либо проблем.)

Кто-нибудь знает почему ??

0

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *